large disk (was large disk and dual boot)

Kristoffer Ekelund bke at technuke.net
Mon Nov 19 15:16:10 PST 2001


On Mon, 19 Nov 2001 00:14:49 -0500 "David" <dareynol at eng.usf.edu> wrote:

> So far the only way I have been able to use this drive is by using the
> OnTrack disk manager. Things seem to be working for now, but I would
> like to
> get things to work without OnTrack since it takes a long time to boot.

I would suggest that this is the core of the problem, I myself had lots of
trouble with a large (30Gb) disk on an older bios that used OnTrack to
access it. The problem is that OnTrack uses some 'proprietary format' on
that drives the overlay is loaded on (at least if I understood the online
help in the OnTrack Diskmanager correctly). This means that even though
the partition table looks okay the data isn't stored in the right place on
the disk anyway so you can't access it using the standard geometry
settings. I tried 'unsetting' the drive overlay and installing win98 (was
going to make my girlfriends computer dualboot) but it overwrote data on
all kinds of partitions forcing me to reinstall OnTrack and reformat :(
 
> I have also tried to use grub but it also has not worked. Also grub
> seems to
> ignore any attempt to tell it to use a different geometry. When using
> the
> command geometry (hd0) 19485 16 63 it just prints the geometry it gets
> from
> the BIOS. Am I using this correctly?
> It seems strange to me though, that grub prints out the partition table
> fine, but can't find any of the files.
> 
> This is very frustrating. Any help is apreciated.

I don't know if this helped you any but it might...

        Sincerely,
        Kristoffer

-- 
Read, think, spread! http://www.toad.com/gnu/whatswrong.html
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list