large disk (was large disk and dual boot)

David dareynol at eng.usf.edu
Sun Nov 18 21:14:49 PST 2001


I still have not figured out how to get LILO to boot this drive (even with
just LFS).
Using either linear or lba32 in lilo.conf I get this error: L 40.
Without it I get: LI
Could this be a geometry problem?

The kernel recognizes the drives geometry as 19485 cylinders, 16 heads, 63
sectors.
I tried using this geometry in the lilo.conf file, but no change from the
above errors. (and yes, I am running /sbin/lilo after making changes to
lilo.conf)

So far the only way I have been able to use this drive is by using the
OnTrack disk manager. Things seem to be working for now, but I would like to
get things to work without OnTrack since it takes a long time to boot.

I have also tried to use grub but it also has not worked. Also grub seems to
ignore any attempt to tell it to use a different geometry. When using the
command geometry (hd0) 19485 16 63 it just prints the geometry it gets from
the BIOS. Am I using this correctly?
It seems strange to me though, that grub prints out the partition table
fine, but can't find any of the files.

This is very frustrating. Any help is apreciated.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list