glibc 2.2.4 configure problem

Andreas Benzing andreas.benzing at nudelsnack.dyndns.org
Wed Nov 14 14:39:50 PST 2001


On Thu, 1 Nov 2001 08:57:34 +0000 (UTC), jeroencoumans at hotmail.com
("Jeroen Coumans") wrote:

I have nealy the same problem:

*** These auxiliary programs are missing or too old: msgfmt
*** some features will be disabled.
*** Check the INSTALL file for required versions.
*** This version of GNU libc cannot be compiled by GCC 3.x.
*** GCC 3.x will generate a library that is binary incompatible to
*** older and future releases of GNU libc.
*** You should compile this GNU libc release by an older GCC version
*** or wait for the next GNU libc release.
*** This configuration is not supported by the GNU libc developers.
checking whether ranlib is necessary... gcc: installation problem,
cannot exec `as': No such file or directory
../glibc-2.2.4/configure: ar: command not found
cp: cannot stat `conftest.a': No such file or directory
../glibc-2.2.4/configure: ranlib: command not found
yes
checking LD_LIBRARY_PATH variable... ok
checking for bash... /bin/sh
checking for mawk... mawk
checking for perl... no
checking for install-info... /usr/bin/install-info
checking for old Debian install-info... no
checking for bison... no
checking for signed size_t type... no
checking for libc-friendly stddef.h... no
checking whether we need to use -P to assemble .S files... yes
checking whether .text pseudo-op must be used... no
checking for assembler global-symbol directive... UNKNOWN
configure: error: cannot determine asm global directive

>This is a problem with binutils. Go back to chapter 5 and reinstall it. Make
>sure that it's statically linked.

That didn't help, but I discovered that ar, as and conftest.a aren't
there! What could be the problem? I didn't find anything in the
install logs of binutils.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list