AW: Re: gcc problem !!

Andre Wyrwa a.wyrwa at web.de
Tue Nov 13 09:37:17 PST 2001


Normally you won't need a statically compiled autoconf to compile gcc.
As I wrote before I had the same problem and solved it (by fortune) 
different. In my opinion it was some link that I missed to dreate in 
chapter 5, but I don't remember anymore.

Andre.

-----Ursprungliche Nachricht-----
Von:	Luqman Munawar [SMTP:Luqman.m at web.de]
Gesendet am:	Dienstag, 13. November 2001 00:14
An:	lfs-support at linuxfromscratch.org
Betreff:	Re: Re: gcc problem !!

Hi Eric,

The problem was solved by installing autoconf statically outside the 
chrooted environnment before moving ahead with gcc.

After this installation of gcc from within the chrooted environment did not 
give the error message any more.

Do not forget to install autoconf statically in chapter 6 again.

I hope someone can give an advice if this solution is not going to have any 
repercussions later.

Regards,
Luqman




lfs-support at linuxfromscratch.org schrieb am 12.11.01:

Hey, I am ahving the exact same problem on Debian 2.2, If you are given 
help
or you solve the problem, I would greatly appreciate it if you would drop 
me
a line.


Thanks,
eric


----- Original Message -----
From: "Luqman Munawar" <Luqman.m at web.de>
To: <lfs-support at linuxfromscratch.org>
Sent: Friday, November 09, 2001 6:04 PM
Subject: gcc problem !!


I am building lfs for the first time and have encountered problems while
installing gcc-2.95.3. I have gone through the archive and tried different
solutions suggested there. I deleted gcc-build and gcc-2.95.3 directories.
Even after untarring again and trying to install gcc the error message
remains the same.

I am using
lfs version 3.0
hostsystem Suse7.1
Chapter 6


OUTPUT -->>
-----------------------------------------------------
cd ../../gcc-2.95.3/gcc; autoconf
/bin/sh: autoconf: command not found
make[1]: *** [../../gcc-2.95.3/gcc/configure] Error 127
make[1]: Leaving directory `/usr/src/g/gcc-build/gcc'
make: *** [bootstrap] Error 2
-------------------------------------------------

The problem occurs in "make bootstrap". I checked the dynamic dependencies
but the needed libraries are also at the right place.

I have only used patches and programs in versions that were recommended.
The timestamp of configure and configure.in in /usr/src/g/gcc-2.95.3/
directory is not matching but what can I do now to overcome the problem and
how could I have changed the timestamp. Just changing the timestamp of one
file to the timestamp of other would solve the problem or would it make
something go wrong later.... ??

I have tried to build gcc now for the 3rd time but the same error message.

thanks for your help you linux gurus,

Luqman
____________________________________________________

________________________________________________________________________  
______
Geben Sie Ihren Lottotipp gerne auf den letzten Drucker ab?Beim WEB.DE
Lottoservice gibt's keine Warteschlangen. http://tippen2.web.de/?x=9

--
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list