problem by building sed-3.02

Massimiliano Aristide Massimo.Aristide at zuehlke.com
Fri Nov 9 01:50:07 PST 2001


hi there,

I've started at the beginning of this week
to build my own Linux system based on lfs-3.0 .

I used Debian 2.2 and tried also with Calderas eDesktop2.4
as the base system. I strictly followed the instructions in
the lfs book of chapter 5. I was able to configure, make and
install all packages except sed-3.02.

the configure script of the sed package worked well but
make failed. here last few line of the trace:

make[2]: Entering directory `/mnt/lfs/usr/src/lfsrc/3.0/sed-3.02/sed'
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../lib  -g -O2 -c sed.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../lib  -g -O2 -c compile.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../lib  -g -O2 -c execute.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../lib  -g -O2 -c utils.c
gcc -g -O2 -static -o sed  sed.o compile.o execute.o utils.o ../lib/libsed.a

/usr/lib/libc.a(regex.o)(.data+0x0): multiple definition of
`re_max_failures'
../lib/libsed.a(regex.o):/mnt/lfs/usr/src/lfsrc/3.0/sed-3.02/lib/regex.c:194
:
first defined here
make[2] *** [sed] Error 1
make[2]: Leaving directory `/mnt/lfs/usr/src/lfsrc/3.0/sed-3.02/sed'
make[1] *** [all-recursiv] Error 1
make[1]: Leaving directory `/mnt/lfs/usr/src/lfsrc/3.0/sed-3.02'
make[1]: *** [all-recursiv] Error 2

I'm somehow lost. I searched for a solution without success for days.
Does somebody have an idea how to fix or work around this problem.

cu
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list