fileutils segfaulting in Ch. 6

Anthony Frazier afrazier at neo.rr.com
Sun Nov 4 21:27:19 PST 2001


Hi all,

I'm trying to build an LFS system and do some funky stuff with it.  Mostly 
use bleeding edge everything, cram XFS support in, etc.

Here's the problem I'm running into: I'm compiling fileutils very early in 
Chapter 6 (right after glibc, actually) because I want to use installwatch on 
everything.  Problem is, the fileutils programs are segfaulting!  I tried 
using the sed commands from Chp 5 (which I didn't need then), but still have 
the same result.

I'm coming from a slightly upgraded Slack 8 (kernel 2.4.13-xfs-preempt, 
modutils 2.4.10, e2fsprogs 1.25, and xfs utilities up), which has gcc 2.95.3 
and glibc 2.2.3 (comes with the distribution, for those who may not know) on 
a Duron 800.

I'm kinda puzzled as to what to try next.  Perhaps recompile gcc first before 
doing anything else?  I've been building LFS systems from this distribution 
(save tracking the latest kernel and file system stuff) for the past few 
months now, doing all kinds of other experimental things that ended up 
ultimately being bad ideas, and I've never had this problem.

Any help is greatly appreciated.  Thanks!

Pax,

Anthony
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list