glibc 2.2.4 configure problem

Brent Miszalski tokra at pop.ihug.com.au
Thu Nov 1 12:43:44 PST 2001


After getting to here http://www.linuxfromscratch.org/view/3.0/ch06-
glibc.html and following the instructions I get this error message:

loading cache ./config.cache
checking host system type... i686-pc-linux-gnuoldld
checking sysdep dirs... sysdeps/i386/elf linuxthreads/sysdeps/unix/sysv
/linux/i386 linuxthreads/sysdeps/unix/sysv/linux linuxthreads/sysdeps/
pthread sysdeps/pthread linuxthreads/sysdeps/unix/sysv linuxthreads/
sysdeps/unix linuxthreads/sysdeps/i386/i686 linuxthreads/sysdeps/i386/
i586 sysdeps/i386/i586 sysdeps/i386/i486 linuxthreads/sysdeps/i386 
sysdeps/unix/sysv/linux/i386/i686 sysdeps/unix/sysv/linux/i386 sysdeps/
unix/sysv/linux sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman 
sysdeps/unix/inet sysdeps/unix/sysv/i386 sysdeps/unix/sysv sysdeps/unix
/i386 sysdeps/unix sysdeps/posix sysdeps/i386/i686/fpu sysdeps/i386/
i686 sysdeps/i386/fpu sysdeps/i386 sysdeps/wordsize-32 sysdeps/ieee754/
ldbl-96 sysdeps/ieee754/dbl-64 sysdeps/ieee754/flt-32 sysdeps/ieee754 
sysdeps/generic/elf sysdeps/generic
checking for a BSD compatible install... /bin/install -c
checking whether ln -s works... yes
checking for pwd... /bin/pwd
checking build system type... i686-pc-linux-gnuoldld
checking for gcc... gcc
checking version of gcc... 2.95.3, ok
checking for gnumake... no
checking for gmake... no
checking for make... make
checking version of make... 3.79.1, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... no
checking for makeinfo... makeinfo
checking version of makeinfo... 4.0, ok
checking for gsed... no
checking for sed... sed
checking version of sed... 3.02, ok
checking whether the C compiler (gcc  ) works... no
checking whether the C compiler (gcc  ) is a cross-compiler... (cached) 
yes
checking whether we are using GNU C... yes
checking build system type... i686-pc-linux-gnuoldld
checking how to run the C preprocessor... /lib/cpp
checking for ranlib... ranlib
checking whether as is GNU as... no
checking whether ld is GNU ld... no
checking for mig... mig
checking whether ranlib is necessary... yes
checking LD_LIBRARY_PATH variable... ok
checking for bash... /bin/sh
checking for mawk... mawk
checking for perl... no
checking for install-info... /usr/bin/install-info
checking for old Debian install-info... no
checking for bison... no
checking for signed size_t type... no
checking for libc-friendly stddef.h... no
checking whether we need to use -P to assemble .S files... yes
checking whether .text pseudo-op must be used... no
checking for assembler global-symbol directive... UNKNOWN
configure: error: cannot determine asm global directive

I'm using a no frills debian install for the host, any ideas?
Thanks For Your Time.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list