Ptrace vulnerability in kernels <2.4.21-pre6

Dagmar d'Surreal dagmar at speakeasy.net
Wed Apr 23 16:42:53 PDT 2003


On Wed, 2003-04-23 at 00:24, Archaic wrote:
> On Wed, Apr 23, 2003 at 06:55:27AM +0200, Damian Wojslaw wrote:
> > 
> > 	It seems that 2.4.20 with OpenWall patch are not vulnerable. At least
> > with my kernel. :)
> 
> Yeah, I've been meaning to try Owl for awhile to see what they are
> doing. But, according to OpenWall, you should be using a 2.2 series
> kernel for maximum security.

Well, the features you get with 2.4 work the same way with 2.2, the 2.2
kernel just has _more_ features that you may or may not feel like using
depending on your need.  People should take YMMV seriously in this case
and analyze which features they need before committing to a particular
kernel tree (up to and including considering that the 2.2.x kernel &
OpenWall patch have had a lot more time to be "field tested")

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-security' in the subject header of the message



More information about the lfs-security mailing list