Konqueror and LFS websites

Andrew Benton b3nton at gmail.com
Sun Jun 6 03:09:11 PDT 2010


On 06/06/10 05:31, Trent Shea wrote:
>> From time to time I'll search for text on a page, typically the string gets
> highlighted, but sometimes the search field will show a hit and nothing will be
> highlighted or the wrong word will be highlighted! I'm pretty sure this is a
> bug in Konqueror. It turns out that tidy can help.
>
> Index: tidy.conf
> ===================================================================
> --- tidy.conf   (revision 9220)
> +++ tidy.conf   (working copy)
> @@ -3,10 +3,9 @@
>   tab-size: 8
>   input-encoding: latin1
>   output-encoding: latin1
> -newline: CRLF
>   write-back: yes
>   markup: yes
> -indent: yes
> +indent: no
>   hide-endtags: no
>   uppercase-tags: no
>   logical-emphasis: no
>
> I experience this on my LFS system and a debian squeeze, both KDE-4.4.x.
>
> A search for intro on lfs or blfs dev will demonstrate both cases described.
> My local copies work properly with the modified tidy.conf.
>
> I doubt this is worth an update to the book for, but I thought I'd share; this
> behaviour has been bothering me for longer than I can remember. That said, a
> switch to kwebkitpart, also works, if you can live without plugins, for now...
> ;).
>
>
Looking at my copy of tidy.conf, it has 2 entries for newline. The first 
is as you've shown, CRLF and the second, at the end of the file, is 
newline: LF
Looking at a locally generated copy of the book, the line endings are LF 
so it seems that tidy is ignoring the first newline: CRLF entry and 
following the second newline: LF

Andy



More information about the lfs-chat mailing list