file problems

Robert Connolly robert at linuxfromscratch.org
Wed May 30 08:44:33 PDT 2007


On Wednesday May 16 2007 09:37:07 am Ken Moffat wrote:
> On Wed, May 16, 2007 at 08:08:42AM -0400, Robert Connolly wrote:
> > I have two guesses. Both of these drives are sata, and use the same
> > controller. Perhaps the controller is damaged. The second guess is
> > linux-2.6.21.1, because these problems began shortly after upgrading the
> > kernel to this version from 2.6.20.2.
> >
> > Have any of you ever had similar issues?
>
>  Not exactly a similar issue, but then I don't use encryption.  On
> my previous "server" everything in /home was backed up several times
> a day (including source tarballs) using rsync to a separate disk
> (with a rolling set of x copies).  One day, a tarball for gcc became
> corrupt.  Searching through the backups of that tarball, they all
> seemed to be corrupt too.  In that case I downloaded it again, but
> eventually I powered the box down, ran memtest86+, and sure enough
> one of the memory sticks had gone bad.
>
>  You said your bios tests the memory, but I tend to have a low
> opinion of bios code (it's probably better than I could write, but
> that doesn't mean it's any good ;).  Try memtest86+.

The bios does a count. It's probably a read-only test.

Everything was fine for about two weeks, although I haven't used the cdrom 
much for the last two weeks, then it happened again yesterday. I was 
unpacking a tarball and the system stopped responding... at first I was able 
to move the mouse but nothing I typed would become displayed. I tried 
<ctrl><alt><f1> to get out of x11, I went out for 30 minutes and when I came 
back it didn't exit x11, and the mouse cursor didn't move anymore.

I ran memtest for 9 hours, it was about 14% complete, and no errors were 
found. I just checked the tarball, and it's not damaged.

It still could be the ram because I didn't complete the memtest, but I'm 
leaning more towards the drive controller. This problem happens while using 
either of two different drives, that share the same controller, and it has 
only happened while doing something as a regular user... root has managed to 
kill some processes that run away, if I get to it quickly enough.

robert
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-chat/attachments/20070530/38d8e7b0/attachment.sig>


More information about the lfs-chat mailing list