file problems

Robert Connolly robert at linuxfromscratch.org
Wed May 16 05:08:42 PDT 2007


Hello. In the last few days I have had some mysterious bugs with my system. 
I'm curious if it's familiar to any of you, because I'm having trouble 
figuring it out.

The problems started with trying to mount a dvdrom while compiling something. 
The 'mount' command would hang, and wouldn't be easily killed. After about 5 
minutes it did eventually die, and did not consume noticeable cpu while it 
was stuck. Soon after I tried to remove a 1.3GB file from /home, which 
is /dev/sdb whole-disc loop-aes encrypted ext3. The 'rm' command got stuck, 
and used 95% cpu. After 10 minutes I decided to reboot, and after rebooting I 
was able to remove the file.

The next day, today, I tried to unpack a tarball on /usr/src, which 
is /dev/sda15 ext3. bzip2, via 'tar xf', failed and complained the file was 
corrupted, even though the file was fine an hour earlier. The file size was 
correct, but the gpg signature was not. So I tried to remove it, and 'rm' 
started using 95% cpu again, and after 10 minutes of that I rebooted 
because 'kill -9' had no effect.

After this reboot I forced a fsck on both drives, and ran 'badblocks' 
read-only tests, and there were no errors. My bios also does memory check, on 
the ram, during boot, and this didn't find any errors. I also run 
the 'smartd' daemon, and it only reported 2 degree temperature changes around 
the time of these problems.

I have two guesses. Both of these drives are sata, and use the same 
controller. Perhaps the controller is damaged. The second guess is 
linux-2.6.21.1, because these problems began shortly after upgrading the 
kernel to this version from 2.6.20.2.

Have any of you ever had similar issues?

robert
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-chat/attachments/20070516/e5f021ba/attachment.sig>


More information about the lfs-chat mailing list