alsa issues

USM Bish bish at touchtelindia.net
Mon Oct 10 07:59:03 PDT 2005


On Sun, Oct 09, 2005 at 10:10:59AM -0500, Randy McMurchy wrote:
> USM Bish wrote these words on 10/09/05 09:36 CST:
> > 
> > 00:11.5  Multimedia  audio controller:  VIA  Technologies,
> > Inc. VT8233 AC97 Audio Controller (rev 30)
>
> Seems to me you need this line in your kernel configuration:
> CONFIG_SND_VIA82XX=y
> as this is my output from lspci:
>
> 00:11.5 Multimedia audio  controller: VIA Technologies, Inc.
> VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
>
> Works for me!
>

Thanks, Randy  ... tried it, as suggested by you and  Tony (in
another mail) but  it seems  there  is something  more to  it.
Kernel 2.6.11.12  comes with  ALSA driver 1.0.8.  The original
error I was getting on dmesg is as follows:

Advanced Linux  Sound Architecture  Driver Version  1.0.8 (Thu
Jan 13 09:39:32 2005 UTC).
ALSA device list:
  No soundcards found.

Then I tried the section given  by Tony. It seems there may be
some other quirks  for my card. The error thrown  out by dmesg
has changed colour !!! It states :

spurious 8259A interrupt: IRQ7.
via82xx: Assuming DXS channels with 48k fixed sample rate.
         Please try dxs_support=1 or dxs_support=4 option
         and report if it works on your machine.

Ha! that's another ball game ;-)

I tried  a few more combinations,  but no joy !  Some days are
just  not your  days  ;-)  Will do  some  more  RTFM, and  try
building a kernel with full  sound support as loadable module,
like in my old 2.2.xx and 2.4.xx kernels where it always seems
to have  worked ... and  keep my fingers crossed  ;-) Probably
there may be some  fix in the new alsa which  is at 1.0.10 now
(I think) ... lets see how that goes.

Thanks again to you and Tony for the lead ...

Cheers,

Bish





More information about the lfs-chat mailing list