lprng/ifhp/gs/ijs/gimp-print

Steven B SilverspurG at yahoo.com
Sat Feb 26 10:10:01 PST 2005


Don't use gimp-print CVS.  Gimp doesn't support the gutenprint name
yet.  Get both gimp-print 4.2.7 and gimp-print 5.0.0beta2.  Gimp-print
is Gutenprint as of 5.0.0beta3 and cvs.

Gimp-print requires gimp to be around to build the ijsgimpprint driver. 
Gimp won't build --with-gimp-print unless gimp-print 4.2.x is installed. 
Gimp will not recognize gimp-print 5.0.0beta2.  Gimp-print 4.2.x, however,
only supports gimp 1.2. Install gimp-print 4.2.7 to satisfy gimp.  Once
gimp (I'm using cvs/2.3) is built, install gimp-print 5.0.0beta2 over the
top of gimp-print 4.2.7. Voila. Gimp-printing.

I use lprng as my spooler, ifhp as my filter, gs as my renderer, ijs as my
device, and ijsgimpprint as the IjsServer.  The important lines in
/etc/printcap are :filter and :ifhp.

/etc/printcap:

lp|lp0|epson
:af=acct
:filter=/usr/libexec/filters/ifhp
:fq
:ifhp=model=gs,gs_device=ijs,gs_options=-sIjsServer=/usr/bin/ijsgimpprint\
-sDeviceManufacturer=EPSON\ -sDeviceModel=escp2-c82\ -dIjsUseOutputFD
:lf=log
:lp=/dev/lp0
:lprngtooloptions=FILTERTYPE="IFHP"
:IFHP_OPTIONS="status@,sync@,pagecount@,waitend@"
:PRINTERDB_ENTRY="ghostscript" mx=0
:rw
:sd=/var/spool/lpd/lp0
:sh




More information about the lfs-chat mailing list