A couple of firefox quirks

Matthew Burgess matthew at linuxfromscratch.org
Sat Oct 30 07:01:02 PDT 2004


Erik-Jan wrote:
> Matthew Burgess wrote:
> 
>> Miguel Bazdresch wrote:
>>
>>> * Matthew Burgess <matthew at linuxfromscratch.org> [2004-10-30 13:07]:
>>>
>>>> Erik-Jan wrote:
>>>>
>>>>> I had the same thing here. Removing "--enable-extensions=all" and 
>>>>> adding one line to .mozconfig made it work for me. Note the dot...
>>>>>
>>>>> . $topsrcdir/browser/config/mozconfig
>>>>
>>>>
>>>>
>>>> Hmm, that's interesting, but BLFS doesn't currently use a .mozconfig 
>>>> file.  It's all done using a ./configure command.  Any ideas how I 
>>>> can transfer your fix to such a build method?  I removed 
>>>> "--enable-extensions=all" from the configure line and also tried 
>>>> "--enable-extensions" both with no effect :(
>>>
>>>
>>>
>>>
>>> Take a look at $topsrcdir/browser/config/mozconfig and translate the
>>> options there to ./configure options.
>>>
>>
>> Thanks Miguel.  The only difference I see there is the 
>> enable-extensions  value.  Doing a(nother) build now, though I doubt 
>> it'll change anything.
>>
>> Cheers,
>>
>> Matt.
> 
> 
> Adding (care for line wrap) 
> --enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth 
> 
> to configure works here.

Confirmed - thanks a bunch :)  It's also stopped the empty dialog box 
from appearing too, though I seem to have lost the ability for it to ask 
me about whether or not I want cookies to be set.  Oh well, I've got the 
Find thing working and no blank dialog boxes now, I'm absolutely 
ecstatic :)  Thanks a lot for everyone's help,

Matt.



More information about the lfs-chat mailing list