getprotobyname problems

Gerard Beekmans gerard at linuxfromscratch.org
Fri Aug 20 09:23:40 PDT 2004


Hi guys,

Hopefully one of you guys can help me out here with a problem. For some
reason the "getprotobyname" function isn't working anymore and this is
causing problems with Perl at the moment.

On a new LFS installation it works just fine and on all other computers
is works fine, so this is a problem that cropped up recently on one of
my servers but I am unable to track it down. I wonder if it's a Glibc
problem or not, but I am not sure how to put together a quick test
program that will tell me as much.

Any of you can help me out here? I will be reinstalling LFS on this
server so the problem will become moot after the weekend. However, I
would like to have it fixed during the weekend too. I'm doing some SNMP
programming in Perl for my boss and I'd like to show him my results.
That's not working right now due to this getprotobyname issue.

Btw this error also shows up during Perl's "make test" and during Perl's
Configure it says that getprotobyname() and getprotobynumber() aren't
found. Which, to me, looks like a Glibc problem.

It works fine on my laptop with the same Glibc version (2.3.2). Maybe
header file issues? /etc/protocols (which is used by getprotobyname) is
present and world readable and is a proper format.

Thanks for any help,

Thanks,

-- 
Gerard Beekmans

/* If Linux doesn't have the solution, you have the wrong problem */




More information about the lfs-chat mailing list