isa pnp

mrnobby no at spam.please
Wed Aug 11 12:33:19 PDT 2004


Calling all PnP experts...

I have a Creative soundcard with one of the IDE ports built in. I am
trying to get it to work as a tertiary IDE port. I'm not interested in
any aspect of the sound/game functions of the card.

But I am having trouble getting it to work under LFS (& Suse 9).

I have the original PnP disk and run the CTCU.EXE config utility via
DOS, it is seen ok, I have disabled everything except the IDE port,
setting it to 0x1e8, 0x3ee and INT 11, which are the generally accepted
'standards' for IDE2. But when I boot into Linux it appears to forget
these settings. The config util does appear to add stuff to config.sys
and autoexec.bat so that it looks like the card gets configured at boot
time rather the settings being set in flash RAM on the card. Maybe a
reboot resets the PnP data?

The card is an ISA card, so I have also tried to ISAPNP tools, the probe
works fine, I've created /etc/isapnp.conf and it loads fine at bootup,
but still no good. Under LFS I cannot see it at all, Under suse I get
the (master) disk shown as /dev/hdg, but cannot access it. It should be
/dev/hde anyway.

I've also tried ide2=0x1e8,0x3ee,11 from the boot and also
hde=<cyl>,<head>,<sec>,<precomp>,11 (with the correct geometry for the
drive!) but this is still useless.

Possible gotchas are: Its a 486 with a PCI bus; there does not appear to
be a "PnP OS?" option in the BIOS which the ISAPNP tools docs say can
help (by telling it that Linux is/not a PNP OS.

Any ideas please?

thanks,

Mr Nobby.





More information about the lfs-chat mailing list