Login trouble

Casey mail at nowhere.com
Thu Sep 26 23:34:39 PDT 2002


Wow, I'm so glad someone else is trying to do this, and running into the
same problems. I've been working on this for the last 3 days with no 
luck. I started hacking the /bin/login program to see why it is failing. 
I tracked it down to a call to getpwnam(). This is returning a NULL
pointer, and login inserts a crypt password of "!". This cause all
possible passwords to fail.petpwnam() is included in pwd.h, part of libc
collection i think. For my use, I don't need the password authentication,
but I haven't found out another way to open up virtual tty terminals, than
by calling agetty and running /bin/login. If anyone has any suggestions to
get by this, please help.

Casey McGinty



On Wed, 25 Sep 2002 10:56:32 +0000, Jeroen Coumans wrote:

> On Tuesday 24 September 2002 18:46, Mihail Popa wrote:
>> No.. that's not it. I had copied the /etc/shadow file also. Tried as
>> you said but same result.
> 
> Did you also try the login utils from shadow? 
> 
>> If I issue "chroot /mnt/linux passwd" I get "Cannot find login name:
>> No such file or directory". Are there any other files passwd needs
>> aside /etc/passwd and /etc/shadow?
> 
> At this point I would suggest using strace (search fm) to further 
> debugging.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-chat' in the subject header of the message



More information about the lfs-chat mailing list