binutils-2.21.1

Rogelio Serrano rogelio.serrano at gmail.com
Tue Feb 14 07:42:52 PST 2012


On Tue, Feb 14, 2012 at 7:51 PM, thorsten <fly_b747 at gmx.de> wrote:
> ld of binutils-2.21.1 and 2.21.1a has a bug when compiling (some) pie code,
> see
>
> https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/663294
>
> This is fixed in 2.22.
>
> I updated the binutils patch and crosschecked my doing with
>
> 63_all_binutils-2.22-pt-pax-flags-20111121.patch of gentoo.
>
> Using this patch with binutils-2.22 makes it possible to compile firefox
> with pie enabled, which resulted in a not starting firefox when using
> 2.21.1*
>
>

wow! this is great so now we can actually have a normally updating
firefox that does not need paxctl to turn off pax flags

are there pie 64 bit firefox binary packages out there?

> --
> http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
> FAQ: http://www.linuxfromscratch.org/faq/
> Unsubscribe: See the above information page
>



-- 
quarq consulting: agile, open source



More information about the hlfs-dev mailing list