cant build pax kernel with ld 2.21.51.0.9

Rogelio Serrano rogelio.serrano at gmail.com
Mon Jun 6 21:08:33 PDT 2011


On Tue, Jun 7, 2011 at 6:32 AM, Robert Connolly
<robert at linuxfromscratch.org> wrote:
> On Monday 06 June 2011 00:41:02 Rogelio Serrano wrote:
>> ld 2.21 is not recognised when building pax kernel. has anyone
>> encountered this problem? i cant figure out how to fix the script that
>> tests the ld version in kbuild.
>
> Try:
> make CC="gcc -fno-PIE -no-fatal-warnings"
>
> The kernel is checking if 'gcc -Wl,--build-id' works, but it's getting a
> warning message, which is fatal, so the test fails.
>
> robert
>
> --
> http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
> FAQ: http://www.linuxfromscratch.org/faq/
> Unsubscribe: See the above information page
>
>

ill try it thanks

-- 
quarq consulting: agile, open source



More information about the hlfs-dev mailing list