SVN20110204 Build Failure

Mr. T mr-t at jabcross.co.uk
Tue Feb 22 01:54:38 PST 2011


On 22/02/2011 04:01, Robert Connolly wrote:
> On Monday 21 February 2011 13:42:30 Mr. T wrote:
>> Hi,
>>
>> I had a go at building this today and came across a build failure.
>>
>> Everything upto and including Chapter 6.11 built exactly as expected.
>> Chapter 6.12 (Binutils) is where I hit the snag.
>>
>> The actual build of Binutils is fine. Running the testsuite had the
>> following result :
>>
>> binutils test - OK
>> gas tests - OK
>>
>> ld tests - Failed
>>
>> For test elfvsb.exp :
>>
>> FAIL: visibility (hidden) (non PIC)
>> FAIL: visibility (hidden) (non PIC, load offset)
>> FAIL: visibility (hidden) (PIC main, non PIC so)
>> FAIL: visibility (hidden_normal) (non PIC)
>> FAIL: visibility (hidden_normal) (non PIC, load offset)
>> FAIL: visibility (hidden_normal) (PIC main, non PIC so)
>> FAIL: visibility (hidden_undef_def) (non PIC)
>> FAIL: visibility (hidden_undef_def) (non PIC, load offset)
>> FAIL: visibility (hidden_undef_def) (PIC main, non PIC so)
>> FAIL: visibility (hidden_weak) (non PIC)
>> FAIL: visibility (hidden_weak) (non PIC, load offset)
>> FAIL: visibility (hidden_weak) (PIC main, non PIC so)
>> FAIL: visibility (protected) (non PIC)
>> FAIL: visibility (protected) (non PIC, load offset)
>> FAIL: visibility (protected) (PIC main, non PIC so)
>> FAIL: visibility (protected_undef_def) (non PIC)
>> FAIL: visibility (protected_undef_def) (non PIC, load offset)
>> FAIL: visibility (protected_undef_def) (PIC main, non PIC so)
>> FAIL: visibility (protected_weak) (non PIC)
>> FAIL: visibility (protected_weak) (non PIC, load offset)
>> FAIL: visibility (protected_weak) (PIC main, non PIC so)
>> FAIL: visibility (normal) (non PIC)
>> FAIL: visibility (normal) (non PIC, load offset)
>> FAIL: visibility (normal) (PIC main, non PIC so)
>>
>> For test elfweak.exp :
>>
>> FAIL: ELF DSO weak data first DSO
>> FAIL: ELF DSO weak data last DSO
>> FAIL: ELF DSO weak data first DSO common
>> FAIL: ELF DSO weak data last DSO common
>>
>> For test shared.exp :
>>
>> FAIL: shared (non PIC)
>> FAIL: shared (non PIC, load offset)
>> FAIL: shared (PIC main, non PIC so)
>>
>> Finally on test srec.exp :
>>
>> FAIL: S-records with constructors
>>
>> It then fails at the end of the ld test section.
>>
>> I've backtracked and checked all the edits I made, they look fine. The
>> configparms file at 6.9 (Glibc) was copied and pasted due to its size
>> and complexity, so Im confident with that.
>>
>> Any thoughts on what may be causing this, or if I have missed a typo
>> somewhere ?
>>
>> Thanks,
>>
>> Steve.
> The 'make CC="gcc -O2 -fno-stack-protector -nopie -fno-PIE" check' should
> cover this.
>
> Please send me ld/ld.log. Also, is this a i686 or an x86_64?
>
> robert
This is the 32-bit build.  I'll run it (the Binutils build) again 
shortly as I removed the build directory late last night. Doh!

While I'm on, some background I meant to add to my previous message but 
forgot :

LiveCD build 2160

CPU : Core2Duo X6800

Mainboard : Intel DG965OT

Physical Memory : 1 Gb

Swap Partition : 2 Gb

The HDD is 500 Gb split into 128 Mb /boot, 2 Gb /swap, all remaining 
space for /, using ext3.

A quite generic affair really, and the same system previously had a 
number of different versions of the regular LFS built on it as well as 
SVN-20080603.

Steve.



More information about the hlfs-dev mailing list