Adjusting Seg Fault

Robert Connolly robert at linuxfromscratch.org
Sun Feb 28 15:55:30 PST 2010


On Sunday February 28 2010 06:21:54 pm Michael DeLuca wrote:
> Trying to fix the warnings didn't help, I got the same error.  I
> started over and found that ld and as that binutils builds work fine
> up until glibc is built and installed.  If I run my tools/ld right
> before building/installing glibc it outputs "ld: no input files"
> After the glibc install it outputs: "Segmentation fault"  The same is
> true for as.  I get the seg fault both before and after the toolchain
> is adjusted...
>
> Any ideas?

If this was me, I would run strace on /tools/bin/ld. If that doesn't turn up 
anything, like missing files, I would start over. At Glibc don't apply any 
patches or modifications. Do:

./configure --prefix=/tools --with-binutils=/tools/bin \
        --with-headers=/tools/include --libexecdir=/tools/lib/glibc \
        --enable-add-ons --enable-bind-now --enable-kernel=2.6.18 \
        --disable-profile \
        --without-gd --without-selinux --infodir=$(pwd)/DESTDIR \
        --mandir=$(pwd)/DESTDIR &&
echo "CFLAGS += -march=i486 -mtune=native" >> configparms &&
make &&
make install

Omit --enable-omitfp --enable-stackguard-randomization for now, and see if 
that works. What cpu is this? Are you running the text files as shell 
scripts, like 'sh ../temporary_system/glibc.txt'?

robert
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/hlfs-dev/attachments/20100228/97109ff1/attachment.sig>


More information about the hlfs-dev mailing list