GCC 4.4.2 SSP and uClibc

Kevin Day thekevinday at gmail.com
Fri Nov 27 09:15:41 PST 2009


On Fri, Nov 27, 2009 at 2:58 AM, Mwanguhya Daniel Murungi
<dmurungi at dicts.mak.ac.ug> wrote:
> Hello,
>
> Don't know what problem ur facing exactly but I now have a working system
> using the SSP from uClibc (0.9.30.1) and GCC (4.2.4).
>
> The issue is to do with how GCC handles SSP on TLS and non TLS systems.
>
> Attached is the patch I used to get it working. It's by Natanel Copa from
> Alpine Linux. Only problem is Robert's FORTIFY_SOURCE patch generates an
> internal compiler error during the build.
>
> I remember u were also interested in Linux PAM on uClibc; am using version
> Linux-PAM-1.0.4 and all is well. I can share the patches if ur still
> interested.
>
> Daniel
>

I had gotten tired of some strange problems in the past and had given up on it.
I have been using Robert's Blowfish patches for some time now.

However, considering all of the changes in both shadow and probably
Linux-PAM, I might at some point take a look at Linux PAM again.
Are you using the latest shadow utils with your Linux PAM?

-- 
Kevin Day



More information about the hlfs-dev mailing list