ALSA + Runtime issues

Daniel Murungi dmurungi at dicts.mak.ac.ug
Thu May 22 08:01:26 PDT 2008


Hello mates, 

Am having issues getting ALSA to work with my HLFS system. (Am following 
instructions from the BLFS book) During compilation of ALSA-libs, the make 
fails with the following error; 

/sources/alsa/alsa-lib-1.0.16/mixer/simple/sbasedl.c:71: undefined reference 
to 'dlsym' 

So i added '-ldl' to the LDFLAGS and alsa-libs compiles fine after this. 

Next, I tried the alsa-plugins and I get the following error;

dsp-protocol.c:98: error: 'PTHREAD_ERRORCHECK_MUTEX_INITIALIZER_NP' 
undeclared (first use in this function) 

After 'googling' for a while, I added the flag '-D_USE_GNU_SOURCE' to the 
CPPFLAGS and the alsa-plugins built without errors 


Next, I tried the ALSA-utils. This builds without any make errors but some 
of the progs seg fault (ie. aplay and speaker-test). This is what is logged 
in /var/log/messages: 

... aplay[18245]: segfault at bf829ffcc eip b7f0e3d3 esp bf821000
... speaker-test[21202]: segfault at bf70effc eip b7edf3d9 


I have tried various flags ("-fPIC -fPIE -f-stack-protector-all", "-fpic 
 -fpie", "-fno-pic -fno-pie -fno-fast-math -fno-stack-protector-all") for all 
the above packages but in the end, i get the same results. 

Am building an asterisk box, and for this; I need mpg123 (which also 
segfaults but am thinking it's due to the alsa issues) 

Need help ASAP coz my boss... (u know the rest) 

I have tried esound but it also has issues. 


NB: Pardon me for not including the full error logs. Am having a hard time 
copying from the console to my firefox window. 

 

Myth: Knowledge is Power
Truth: APPLIED Knowledge is Power



More information about the hlfs-dev mailing list