RPM5 Build Errors

Daniel Murungi dmurungi at dicts.mak.ac.ug
Wed Mar 5 01:57:31 PST 2008


Hello 

Thanks Robert for the HLFS SVN-20080222, it builds without issues (apart 
from the tests, some sym links, and psmisc which istaken care of in the 
devel archives). 

I have tried to build RPM for my hlfs but I get the following error;
make[2]: Leaving directory `/sources/rpm-5.0.3/rpmconstant'
Making all in tools
make[2]: Entering directory `/sources/rpm-5.0.3/tools'
gcc -DHAVE_CONFIG_H -I. -I..  -I. -I.. -I../lib -I../rpmdb -I../rpmio 
 -I../misc -I../db3 -I../db3  -DRPM_OS_LINUX=020621  -g -O2 -fPIC -DPIC -fpie 
 -D_GNU_SOURCE -D_REENTRANT -MT rpm2cpio.o -MD -MP -MF .deps/rpm2cpio.Tpo -c 
 -o rpm2cpio.o rpm2cpio.c
rpm2cpio.c: In function 'main':
rpm2cpio.c:15: warning: not protecting local variables: variable length 
buffer
mv -f .deps/rpm2cpio.Tpo .deps/rpm2cpio.Po
/bin/sh ../libtool --tag=CC   --mode=link gcc  -g -O2 -fPIC -DPIC -fpie 
 -D_GNU_SOURCE -D_REENTRANT  -pie -o rpm2cpio rpm2cpio.o 
../build/librpmbuild.la ../lib/librpm.la ../rpmdb/librpmdb.la 
../rpmio/librpmio.la ../misc/librpmmisc.la  -lpopt -lbeecrypt -lpthread
gcc -g -O2 -fPIC -DPIC -fpie -D_GNU_SOURCE -D_REENTRANT -pie -o 
.libs/rpm2cpio rpm2cpio.o  ../build/.libs/librpmbuild.so 
/sources/rpm-5.0.3/lib/.libs/librpm.so -L/sources/rpm-5.0.3/db3 
 -L/sources/rpm-5.0.3/zlib -L/sources/rpm-5.0.3/file/src 
 -L/sources/rpm-5.0.3/file 
 -L/sources/butterfly-build/i686-pc-linux-uclibc/libstdc++-v3/src 
 -L/sources/butterfly-build/i686-pc-linux-uclibc/libstdc++-v3/src/.libs 
 -L/sources/butterfly-build/./ld -L/sources/butterfly-build/./gcc 
 -L/usr/lib/gcc/.. ../lib/.libs/librpm.so 
/sources/rpm-5.0.3/rpmdb/.libs/librpmdb.so ../rpmdb/.libs/librpmdb.so 
/sources/rpm-5.0.3/rpmio/.libs/librpmio.so ../rpmio/.libs/librpmio.so 
/sources/rpm-5.0.3/misc/.libs/librpmmisc.so ../misc/.libs/librpmmisc.so 
/usr/lib/libpopt.so -lc /usr/lib/libbeecrypt.so -ldl /usr/lib/libstdc++.so 
/lib/libintl.so /usr/lib/libssp.so /usr/lib/libintl.so -lpthread  
 -Wl,--rpath -Wl,/opt/rpm5/lib
/usr/lib/libssp.so: warning: the 'gets' function is dangerous and should not 
be used.
../build/.libs/librpmbuild.so: undefined reference to `xmalloc'
/sources/rpm-5.0.3/misc/.libs/librpmmisc.so: undefined reference to 
`inflate'
../build/.libs/librpmbuild.so: undefined reference to `xstrdup'
../build/.libs/librpmbuild.so: undefined reference to `xcalloc'
../build/.libs/librpmbuild.so: undefined reference to `xrealloc'
/sources/rpm-5.0.3/misc/.libs/librpmmisc.so: undefined reference to 
`inflateEnd'
/sources/rpm-5.0.3/misc/.libs/librpmmisc.so: undefined reference to 
`inflateInit2_'
collect2: ld returned 1 exit status
make[2]: *** [rpm2cpio] Error 1
make[2]: Leaving directory `/sources/rpm-5.0.3/tools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/sources/rpm-5.0.3'
make: *** [all] Error 2
root:/sources/rpm-5.0.3# cd .. 


I also tried earlier versions of rpm ( 4.4 ,4.3, 4.2, 4.0) but get errors as 
well. The only limited success I have had is with version 4.0.4 which runs 
but has some SSP related issues; 

root:/sources# /opt/rpm2/bin/rpm --help
Usage: rpm [OPTION...] 

Query options (with -q or --query):
  -c, --configfiles                list all configuration files
  -d, --docfiles                   list all documentation files
  --dump                           dump basic file information
  -l, --list                       list files in package
  --queryformat=QUERYFORMAT        use the following query format
  -s, --state                      display the states of the listed files
  -v, --verbose                    display a verbose file listing
  -a, --all                        query/verify all packages
  -f, --file                       query/verify package(s) owning file
  -g, --group                      query/verify package(s) in group
  -p, --package                    query/verify a package file (i.e. a 
binary
                                   *.rpm file)
*** stack smashing detected ***: rpm terminated
Illegal instruction 

If anyone has successfully built working rpm binaries for HLFS, please help



More information about the hlfs-dev mailing list