network problems

Chris Buxton cbuxton at menandmice.com
Sun Feb 3 00:04:41 PST 2008


After building another HLFS system based on glibc and linux 2.6, again using package users, the ip command is once again unable to bring up a link.

# ip link set eth0 up
RTNETLINK answers: Invalid argument
# ip link set lo up
RTNETLINK answers: Invalid argument
# ls /sys/class/net
eth0    lo
# ip link show
1: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0c:29:a1:1e:4f brd ff:ff:ff:ff:ff:ff
2: lo: <LOOPBACK> mtu 16436 qdisc noqueue 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

However, I built and installed the old net-tools package (after fixing some errors in the source). The ifconfig is able to bring up the interfaces:

# ifconfig lo up
# ifconfig eth0 up
[  547.429973] eth0: link up
# ip link show
1: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0c:29:a1:1e:4f brd ff:ff:ff:ff:ff:ff
2: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

Is there some necessary kernel configuration option that I've missed to make ip work right? If that's not it, what does ifconfig have that ip doesn't?

Chris Buxton
Professional Services
Men & Mice
Address: Noatun 17, IS-105, Reykjavik, Iceland
Phone:   +354 412 1500
Email:   cbuxton at menandmice.com
www.menandmice.com
 
Men & Mice
We bring control and flexibility to network management
 
This e-mail and its attachments may contain confidential and privileged information only intended for the person or entity to which it is addressed. If the reader of this message is not the intended recipient, you are hereby notified that any retention, dissemination, distribution or copy of this e-mail is strictly prohibited. If you have received this e-mail in error, please notify us immediately by reply e-mail and immediately delete this message and all its attachment.

----- Original Message -----
From: "Chris Buxton" <cbuxton at menandmice.com>
To: "Hardened LFS Development List" <hlfs-dev at linuxfromscratch.org>
Sent: Friday, January 4, 2008 12:50:05 PM (GMT-0800) America/Los_Angeles
Subject: network problems

Hello,

I've build an HLFS (glibc, kernel 2.6) system, with just the following  
modifications:

- using kernel 2.6.19.7 instead of 2.6.19.2
- the package user system of package management

I need help figuring out why I can't bring up any network interfaces.

# ip link set eth0 up
RTNETLINK answers: Invalid argument
# ip link set lo up
RTNETLINK answers: Invalid argument
# ls /sys/class/net
eth0    lo

The build host was the LFS live CD, and the architecture is a VMware  
Workstation 5 machine with the buslogic SCSI adaptor instead of LSI  
Logic, running on an Intel Core Duo.

Chris Buxton
Professional Services
Men & Mice
Address: Noatun 17, IS-105, Reykjavik, Iceland
Phone:   +354 412 1500
Email:   cbuxton at menandmice.com
www.menandmice.com

Men & Mice
We bring control and flexibility to network management

This e-mail and its attachments may contain confidential and  
privileged information only intended for the person or entity to which  
it is addressed. If the reader of this message is not the intended  
recipient, you are hereby notified that any retention, dissemination,  
distribution or copy of this e-mail is strictly prohibited. If you  
have received this e-mail in error, please notify us immediately by  
reply e-mail and immediately delete this message and all its attachment.



-- 
http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
FAQ: http://www.linuxfromscratch.org/faq/
Unsubscribe: See the above information page




More information about the hlfs-dev mailing list