journal

goodoldmarty at gmail.com goodoldmarty at gmail.com
Sun Sep 2 07:35:31 PDT 2007


I have observed a issue with ext3 from the beginning. After considerable
digging I am still not sure of the origin or reason.

My grsec patched kernel has all ext3 options enabled as built-in, not
Modules. All the grsec/PAX options are enabled as well.

All my partitions were formatted ext3 with a journal.

Now on boot, the partition mounts with this warning...
EXT2-fs warning (device hdb1): ext2_fill_super: mounting ext3 filesystem
as ext2

-su-3.2# mount
/dev/hdb1 on / type ext3 (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid)
devpts on /dev/pts type devpts (rw,nosuid,gid=4,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev)

Attempts to mount other ext3 partitions meet this fate:
-su-3.2# mount /dev/hda2 /mnt/x
mount: unknown filesystem type 'ext3'

but I can mount it as ext2 with no problem.

Meanwhile I have mounted my root partition on my another system and run
e2fsck multiple times but when I reboot the times mount times are way
messed up, a check is forced, and I still get this mess:

-su-3.2# tune2fs -l /dev/hdb1
tune2fs 1.40.2 (12-Jul-2007)
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          0af56e50-238c-44fd-b9fc-3f4426905d41
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal resize_inode filetype sparse_super
large_file
Default mount options:    (none)
Filesystem state:         not clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              610432
Block count:              1220806
Reserved block count:     61040
Free blocks:              632882
Free inodes:              522306
First block:              0
Block size:               4096
Fragment size:            4096
Reserved GDT blocks:      298
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         16064
Inode blocks per group:   502
Filesystem created:       Thu Aug 23 15:29:53 2007
Last mount time:          Sun Sep  2 09:12:02 2007
Last write time:          Sun Sep  2 09:42:38 2007
Mount count:              23
Maximum mount count:      29
Last checked:             Wed Aug 29 19:58:58 2007
Check interval:           15552000 (6 months)
Next check after:         Mon Feb 25 18:58:58 2008
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128
Journal inode:            8
Default directory hash:   tea
Directory Hash Seed:      c0f90fe1-88c6-43b7-a611-f1151cb56348
Journal backup:           inode blocks
-su-3.2#

Are there some file system compatibility issues?
I am missing something obvious but the answer eludes me so far.

Marty B

-- 

|\  /|  Visit http://www.goodoldmarty.com today!
| \/ |  ==============================================
|    |  "Opportunity often comes dressed in overalls
******   and disguised as work." Thomas Edison





-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3651 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.linuxfromscratch.org/pipermail/hlfs-dev/attachments/20070902/614c1845/attachment.bin>


More information about the hlfs-dev mailing list