ssl/ssh problem

goodoldmarty at gmail.com goodoldmarty at gmail.com
Mon Oct 22 18:17:28 PDT 2007


I have never seen this before.
on this last development build (SVN-20071022) I have run into a really 
annoying problem trying to get ssh working. So, I reloaded fresh source 
and rebuilt ssh by the BLFS book, booting natively. I removed the sed 
for static linking.
Then I rebuilt ssh fresh as well.
Same result.
Well, I tried it a third and forth time with other mods to no better 
result. I see no reason in the config.logs, or otherwise, but I end up 
with:

Generating public/private dsa key pair
/bin/sh: line 16: 18160 Illegal instruction
ssh_host_dsa_key -N ""

same thing for rsa key.

and therafter it can't load host key. This is a duh of course.

Where is the illegal instruction coming from? Any idea where I goofed?

Perl raises a fit about Locale, but that's never been an issue before.
I have built these packages previously without a whimper, so I think 
there may be a compiler issue involved.



More information about the hlfs-dev mailing list