Issues building Glbc+Linux-2.6

M.Canales.es macana at macana-es.com
Thu Jun 21 11:19:08 PDT 2007


El Miércoles, 20 de Junio de 2007 21:32, Robert Connolly escribió:

> > First, when running the Cocoon sanity checks there is no
> >
> > *** stack smashing detected ***: ./strcat-overflow-ssp terminated
>
> Did you use the fstack-protector patch?

After using the fstack-protector patch, together with all other features 
patches, there is yet no error output from that check command.
 
Now, in Glibc testsuite I have this failed test:

*** [/sources/glibc-build/elf/check-localplt.out] Error 1

And later the build bomb on butterfly-tolchain stage when configuring 
ini686-pc-linux-gnu/libstdc++-v3 with:

checking for C locale to use... gnu
checking for msgfmt... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for library containing gettext... configure: error: Link tests are 
not allowed after GCC_NO_EXECUTABLES.
make[2]: *** [configure-target-libstdc++-v3] Error 1

I see that error also one or two weeks ago (few days before you desactivates 
the features selector) when trying to do a Glibc+linux-2.4 build.

I have the build scripts and logs if you want to look at.

-- 
Manuel Canales Esparcia
Usuario de LFS nº2886:       http://www.linuxfromscratch.org
LFS en castellano: http://www.escomposlinux.org/lfs-es http://www.lfs-es.info
TLDP-ES:                           http://es.tldp.org



More information about the hlfs-dev mailing list