Current HLFS build

Charity charity at orlandotelco.net
Mon Feb 5 08:28:29 PST 2007


Charity wrote:
> Kevin Day wrote:
>   
>>> udev had to be updated. I used udev-105
>>>     
>>>       
>> Interesting, I have udev-094, anything higher causes the system to not
>> boot.  I have been wondering if they changed how their stuff works but
>> made no documentation of it..considering that project has negatives in
>> the areas of information about itself..
>> It took me a while to figure out udev versions higher than 094 were
>> causing my system to not boot.  Did you have similar problems until
>> you changed to 105? I do not belive I have tried 105 as of yet, but I
>> have tried 104.
>>   
>>     
> I could not get udev-081 to compile which was what was suggested in the 
> book. I just took the most recent version and it compiled and installed 
> cleanly. I didn't have a chance to try to boot from it actually because 
> of my kernel snaffoo. I will keep this in mind, but I will try udev-105 
> first. If I can't boot, I will go back to 094. Thanks for the heads up.
>   
Correction. Forgot I did have a problem with udev. It did not 
automatically copy the udevstart binary. I did a locate on it and it was 
nowhere on my system except in my recently built udev directory...so, I 
manually copied this into /sbin and then typed /sbin/udevstart. I 
checked my /dev folder and it looked like all my devices where there 
correctly. Perhaps that is the problem with the newer udevs? If the 
bootscripts expect the /sbin/udevstart to be there, then that could 
cause a problem. :)




More information about the hlfs-dev mailing list