Current HLFS build

Kevin Day thekevinday at gmail.com
Mon Feb 5 07:56:21 PST 2007


On 2/5/07, Charity <charity at orlandotelco.net> wrote:
> gmp and mpfr are supposedly required for building gcc. It actually
> builds without it, but I decided to go ahead and install those packages
> prior to the gcc build.

Aside from your noted testsuite requirement.  These packages are
required by either at least gcc-4.2.0 or at least gcc-4.3.0.  And with
the way things have been going it may be a bout the time gcc-4.2.0 or
gcc 4.3.0 comes out that this project starts becoming "stable".

>
> udev had to be updated. I used udev-105
>
Interesting, I have udev-094, anything higher causes the system to not
boot.  I have been wondering if they changed how their stuff works but
made no documentation of it..considering that project has negatives in
the areas of information about itself..
It took me a while to figure out udev versions higher than 094 were
causing my system to not boot.  Did you have similar problems until
you changed to 105? I do not belive I have tried 105 as of yet, but I
have tried 104.

> I used the most recent kernel 2.6.19.2 and had to update the grsecurity
> patch for it. After that, I got stuck because of the incorrect assert
> defines described elsewhere in this list. :) Starting over again. This
> time I will get the gcc test working so that I can actually test it
> before the install.
Any other problems with 2.6.19, I have found it to cause obscure bugs
and I am of the feeling that 2.6.19 is broken and should not be used
(the feeling might be mutual).  It actually caused my dhcpclient
(dhcpclient-snap) to stop working.  Perhaps some of the more obscure
bugs are related to 2.6.19, try 2.6.18 with the grsecurity patch.

>
> Charity

Theres one things you forgot to mention, are you using uClibc or glibc?
I imagine that will help the hlfs team answer your questions.
I have not been to the site for a while, so maybe they removed the uClibc link..


As further notes, I have noticed that gcc-4.1.1 and uClibc 0.9.28{,.1}
= problem, but I have isolated it down to some possible memory leaks
and hope to somehow find a fix, but I'd rather wait for uClibc-0.9.29.
<-- It's either a problem with threads and something is not locking
safely or dl_cleanup is NOT cleaning up and leaking memory (which is
where valgrind keeps pointing the finger) and there is some relation
to stdrup, but stdrup only leaks when some apps, such as qingy go into
an odd infinite loop and I have to abort the proccess, so perhaps the
unclean abort causes the memory to not be properly deallocated, but
there are problems there as well).  I am also at a loss as to why
sshfs (perhaps fuse in general, but I have yet to test other fuse
modules) is segfaulting on a command such as 'df', but ls works..

with gcc-3.4.6, on both glibc (an old one whose version I do not
remember, I have never gone back to glibc once I got off...fat
libraries slow the cpu down to much) and uclibc cause openssh to hang
in an infinite loop upon logon, for reasons beyond me at the moment.


To truly sum up all of the problems in the linux world..
People are very busy,
A lot of work needs to be done,
projects are being forcefully speed up,
and no one is getting paid.

But at least this means that the developers of the linux world
actually care about what they create.
-- 
Kevin Day



More information about the hlfs-dev mailing list