5.2. Embryo Toolchain - Stages differs (ggc-common.o)

Jan Dvořák mordae at thirdcms.org
Fri Sep 15 08:55:56 PDT 2006


Hi,

	I tried to build 5.2. last night and got this error (./ggc-comon.o
differs). Very similar problem has already been reported according
google in
<http://linuxfromscratch.org/pipermail/hlfs-dev/2006-August/003198.html>
so I followed Robert's hint to CFLAGS="-fno-stack-protector -no-pie",
but I end up with another error. It is not possible to set CFLAGS like
this as we don't include SSP and PIE in stage1 xgcc so it fails as it
don't know anything about them.

	I'm using gcc-3.4.4 (ssp) with glibc-2.3.6 (it's old HLFS). I guess I
may be able to compile it without bootstrap, but I just want to figure
this out.

- Mordae



More information about the hlfs-dev mailing list