uclibc-snapshot and gcc-4.1.1 ssp

Robert Connolly robert at linuxfromscratch.org
Thu Jun 15 20:21:24 PDT 2006


Hi. I'm having problems getting ssp working with uclibc-20060613 and 
gcc-4.1.1. Anything I build with -fstack-protector-all does a Segmentation 
fault, but -fstack-protector seems to be okay. This happens after the second 
gcc is installed. I have tried everything I can think of, and I'm out of 
ideas.

In the second gcc I'm using 'make gcc_cv_libc_provides_ssp=yes', with and 
without --disable-libssp. When I rebuild uClibc with the second gcc then 
everything in /tools segfaults, so it looks like the segfault is coming from 
libuClibc.so (because our uClibc config file builds uClibc with 
-fstack-protector*).

I have my non-working uclibc differences here:
http://www.linuxfromscratch.org/~robert/new/uclibc_gcc-4.1.1-HLFS.txt

P.S.
I have had the same results with binutils-2.16.93 and 2.16.94. 2.16.93 is 
known to be working with uClibc, 2.16.94 was released this week but seems to 
be okay.

robert



More information about the hlfs-dev mailing list