HLFS-uClibc, module-init-tools is installing in /usr/local

Dermot Bradley tangram at nildram.co.uk
Wed Jan 18 10:58:31 PST 2006


> I'm not reproducing it. When I follow the instructions in
> chapter06/module-init-tools.html, it tries to install "lsmod" to "//bin".
>
> Please also report any modifications of the instructions of the hlfs-book,
> additional packages, and libc type and version.
>
> Also, after running ./configure (and maybe make), run:
>
> grep -m 1 -n "prefix =" Makefile
>
> and check if "prefix = /".

I just checked this out on my Debian box - when I ran "./configure
--prefix=/ --enable-zlib" and then checked the created "Makefile" it
contained this:

   prefix = /

Then I ran:

   make DOCBOOKTOMAN=""
   make check

and again checked "Makefile" and it then contained:

   prefix = /usr/local

So, the "make check" is modifying the "prefix" setting and so the
instructions need to be changed to resemble what LFS-SVN currently
has...I've changed my HLFS-uClibc-SVN profile according and am rebuilding.




More information about the hlfs-dev mailing list