Xorg 6.9 & BUG #5585

Declan Moriarty junk_mail at iol.ie
Fri Jan 13 00:22:25 PST 2006


Recently, Somebody Somewhere wrote these words
> > Right compiled again, and still get the same error. The
> > -nonow patch went in (1 hunk), the other 2 already there. Kevin
> > Day's Mesa-Stop_Asking went in. All appropriate seds, and bodges
> > and it built through, but falls over on Xorg -configure 
> > 
> > The url above says
> > 
> > dlloader will not work when LD_BIND_NOW is set, or when the
> > modules are linked with '-z now' as in gentoo-hardened.  this is
> > unavoidable until we abandon LoadSubModule for link-time
> > dependencies.  you'll get an error message about LD_BIND_NOW
> > though.  
> Right, I haven't tested with these hardened flags yet.  Xorg's Modular development with very little documentation had too many potential problems, so I am not using (or forcing) any hardened flags of any kind.
> 
> > 
> > Workaround: fix your scripts to clear LD_BIND_NOW before starting X 
> > Workaround (maybe): export LD_BIND_NOT=1 before starting X.
> > 
> > Sure enough, it complains that LD_BIND_NOW is set. Using 
> > 
> > export LD_BIND_NOW="" kills that error, but not the problem
> > export LD_BIND_NOT=1 does nothing.
> > 
> I'll make sure to look into that.
> 
> > Is there any workaround for this before someone writes a -nonow
> > patch for Xorg-6.9.0 or Xorg-7.0.0?
> The bug(s) fixed in the old monolithic tree  by the hlfs team probably still exist in the new xorg.  Now, it just needs to be converted, perhaps?
> 

Seeing as they were admitting it's broken, I filed a bug #5585 in
bugs.freedesktop.org.

They want to know how to detect a hardened compiler. I sent them
the hardened specs script and the gcc stack-smashing test program.
Any better ways to get this done with a configure test?

-- 

	With best Regards,


	Declan Moriarty.



More information about the hlfs-dev mailing list