Xorg 6.9 LD. To BIND or NOT

Declan Moriarty junk_mail at iol.ie
Wed Jan 11 04:39:11 PST 2006


Recently, Somebody Somewhere wrote these words
> Huston, we got a problem...
> 
> http://freedesktop.org/~ajax/dlloader-status.txt
>  
> > dlopen: /usr/X11R6/lib/modules/drivers/radeon_drv.so: undefined
> > symbol: drmGetLibVersion
> > (EE) Failed to load /usr/X11R6/lib/modules/drivers/radeon_drv.so

> How do I get around this? 2 of the three hunks of the -nonow patch
> are applied by Xorg and I'm going to check the last bit was by me
> or recompile.
> 
> Any offers  what to try as LDFLAGS when recompiling?

Right compiled again, and still get the same error. The
-nonow patch went in (1 hunk), the other 2 already there. Kevin
Day's Mesa-Stop_Asking went in. All appropriate seds, and bodges
and it built through, but falls over on Xorg -configure 

The url above says

dlloader will not work when LD_BIND_NOW is set, or when the
modules are linked with '-z now' as in gentoo-hardened.  this is
unavoidable until we abandon LoadSubModule for link-time
dependencies.  you'll get an error message about LD_BIND_NOW
though.  

Workaround: fix your scripts to clear LD_BIND_NOW before starting X 
Workaround (maybe): export LD_BIND_NOT=1 before starting X.

Sure enough, it complains that LD_BIND_NOW is set. Using 

export LD_BIND_NOW="" kills that error, but not the problem
export LD_BIND_NOT=1 does nothing.

Is there any workaround for this before someone writes a -nonow
patch for Xorg-6.9.0 or Xorg-7.0.0?

--

	With Best Regards,



	Declan Moriarty.



More information about the hlfs-dev mailing list