Java compile under HLFS

Aki Tuomi cmouse at youzen.ext.b2.fi
Sun Jan 8 08:40:03 PST 2006


On Sun, Jan 08, 2006 at 01:42:29PM +0200, Aki Tuomi wrote:
> Some things to consider when compiling Java:
> 
> First of all, you will need gcc 2.95. Just install it under
> /opt/something and use ALT_GCC29_COMPILER_PATH to tell the install root
> of gcc-2.96
> 
> I have it under /opt/gcc2, so i set ALT_GCC29_COMPILER_PATH="/opt/gcc2"
> 
> Then, unlike BLFS, you _will_ have to set CXXFLAGS and CFLAGS to this
> value:
> 
> export CFLAGS="-fno-stack-protector-all -pie -fpie"
> export CXXFLAGS="-fno-stack-protector-all -pie -fpie"
> 
> Java *will not work* with stack protector, so disable it. You don't need
> to set INSANE=yes with this. I am still working on with few problems
> with the java build but am sure that I can work them out.  
> 
> Aki Tuomi
> -- 
> http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
> FAQ: http://www.linuxfromscratch.org/faq/

Some further progress information:

It seems that the Java JDK 1.5.0 requires quite a few changes before it 
agrees to build. The JRL package seems not to include all files required
to compile Java. These have to be loaned from the jdk1.5.0 distribution. 

I will try to make a proper list of all changes I have to make to get
java compile cleanly. 

Aki



More information about the hlfs-dev mailing list