Xorg -configure Duplicate symbol (6.8.2)

Declan Moriarty junk_mail at iol.ie
Tue Feb 28 06:19:39 PST 2006


Recently, Somebody Somewhere wrote these words
> 
> Just for the fun of it, ...meh, I have recompiled 6.8.2 with a
> new buildscript. (the buildscript has been filled with the HLFS
> xorg-6.8.2 build commands, copied from the page, so no typos (of
> mine) ) Again, Xorg -configure failed, so I tried 6.9.  I'm not
> sure if I understood your post correctly. I have tried with
> either of your gcc specs files in /usr/lib/gcc/2.6.14.6/ and
> have built 6.9 with the same 6.8.2 buildscript, except for the
> patches. The nonow patch could actually be applied, but I'm not
> sure whether I still need to with these spec files.  So in total
> I have run four compilations of Xorg 6.9 now.  With and without
> the -nonow patch and with either the specs file or the specs.old
> file.
> 
> Unfortunately, the build fails with this error:
> 
> gcc -m32 -o xdm -O2 -fno-strength-reduce
> -fno-strict-aliasing -march=i686 -ansi -Wall -Wpointer-arith
> -Wundef     -L../../exports/lib   auth.o daemon.o server.o
> dpylist.o dm.o error.o file.o            netaddr.o reset.o
> resource.o protodpy.o policy.o                session.o socket.o
> streams.o util.o xdmcp.o mitauth.o                genauth.o
> access.o choose.o  prngc.o            xdmauth.o rpcauth.o
> greet.o verify.o Login.o -lXpm -lXmu -lXt -lSM -lICE -lXext
> -lX11 -lXt -lSM -lICE -lXext -lX11 -lXau     -lXdmcp -lrpcsvc
> -lcrypt  -lXinerama        -Wl,-rpath-link,../../exports/lib
> /usr/bin/ld: cannot find -lrpcsvc collect2: ld gaf exit-status 1
> terug make[4]: *** [xdm] Fout 1 make[4]: Leaving directory
> `/usr/src/xorg/xcbuild/programs/xdm' make[3]: *** [all] Fout 2
> make[3]: Leaving directory `/usr/src/xorg/xcbuild/programs'
> make[2]: *** [all] Fout 2 make[2]: Leaving directory
> `/usr/src/xorg/xcbuild' make[1]: *** [World] Fout 2 make[1]:
> Leaving directory `/usr/src/xorg/xcbuild' make: *** [World] Fout
> 2
> 
> (I do have /usr/include/rpcsvc/)
> 
> What have I missed?

I think it's in ~/xcbuild/programs/xdm/Makefile

	RPCLIB = -lrpcsvc

Just delete it. grepping for RPCLIB sorts you out.


The other gotchas:

http://www.linuxfromscratch.org/pipermail/hlfs-dev/2006-January/002705.html

Instead of Kevin Day's Mesa patch, I ended up with the one from here

http://bugs.freedesktop.org/show_bug.cgi?id=4197

And although I may not have made it clear, I followed the Xorg-6.8.2 page 
from the book pretty completely. You don't actually need any of the 6.8.2 
patches for 6.9.0, as the developers have largely adopted them. But the sed 
commands before, & methodology are all similar.

There is a later set of instructions in January which include DRI

http://www.linuxfromscratch.org/pipermail/hlfs-dev/2006-January/002745.html

and you might even get lucky. I got DRI only to discover the video card 
I have is useless.
--

	With Best Regards,


	Declan Moriarty.



More information about the hlfs-dev mailing list