Xorg -configure Duplicate symbol (6.8.2)

Warren Wilder wipwap19 at hotmail.com
Tue Feb 28 04:04:29 PST 2006


Sorry, I posted a wrong directory below. I meant 
(/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/)

>From: "Warren Wilder" <wipwap19 at hotmail.com>
>Reply-To: Hardened LFS Development List <hlfs-dev at linuxfromscratch.org>
>To: hlfs-dev at linuxfromscratch.org
>Subject: Re: Xorg -configure Duplicate symbol (6.8.2)
>Date: Tue, 28 Feb 2006 11:56:36 +0000
>
>>From: Declan Moriarty <junk_mail at iol.ie>
>>Reply-To: Hardened LFS Development List <hlfs-dev at linuxfromscratch.org>
>>To: Hardened LFS Development List <hlfs-dev at linuxfromscratch.org>
>>Subject: Re: Xorg -configure Duplicate symbol  (6.8.2)
>>Date: Mon, 27 Feb 2006 17:26:58 +0000
>>
>>Recently, Somebody Somewhere wrote these words
>> > I compiled Xorg 6.8.2 sucessfully, but when I run Xorg -configure I get 
>>the
>> > following output.
>> >
>> > /*************/
>> >
>> > Current Operating System: Linux HLFS 2.6.14.6-grsec #17 PREEMPT Sun Feb 
>>26
>> > 17:42:13 CET 2006 i686
>> > Build Date: 25 February 2006
>> >        Before reporting problems, check http://wiki.X.Org
>> >        to make sure that you have the latest version.
>> > Module Loader present
>> > Markers: (--) probed, (**) from config file, (==) default setting,
>> >        (++) from command line, (!!) notice, (II) informational,
>> >        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
>> > (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 27 16:11:30 2006
>> > Duplicate symbol __i686.get_pc_thunk.bx in
>> > /usr/X11R6/lib/modules/fonts/libbitmap.a:bitmapmod.o
>> > Also defined in /usr/X11R6/lib/modules/fonts/libbitmap.a
>> >
>> > Fatal server error:
>> > Module load failure
>> >
>> >
>> > Please consult the The X.Org Foundation support
>> >         at http://wiki.X.Org
>> > for help.
>> > Please also check the log file at "/var/log/Xorg.0.log" for additional
>> > information.
>> >
>> > /*************/
>> >
>> > Dmesg doesn't hold anymore info about the error. I read around and
>> > understand that this has something to do with the X module loader.
>> > Therefore I expected an issue with this flag in the host.def file.
>> > #define MakeDllModules    YES
>> >
>> > I have tried building with and without it, but that didn't help.
>> >
>> > Building  Hardened Linux From Scratch - Version SVN-20060122.
>> > Other than X, everything seems to be fine.
>> >
>> > I'd appreciate a few suggestions.
>>
>>Open the tarball and go again. I suspect a typo. Or you could try
>>Xorg-6.9.0 according to the instructions I posted or xorg-7.0.0
>>with Kevin Day's script.
>>
>>The issue is that dlloader has problems with hardened systems
>>which link with -z now, and some one of the commands alter that on
>>a big heap of Makefiles. It needs the -nonow switch, which doesn't
>>go handily into X.
>>
>>I got different behaviour from one of the sed commands here doing
>>this. The obvious symptom was that sometimes it took 2 seconds to
>>return a prompt, and sometines returned it immediately
>>
>>I suspect mouse or screen type issues. The screen size hops
>>all over the place when you're going from console to X and I have
>>seen screen width and length strangeness interfere with things here.
>>The console programs lose track of the current screen size. So the
>>mouse can only navigate the top half of the screen, or 20 spaces
>>are included (Or 20 characters left out) when you copy & paste 2
>>lines.
>>
>>I got a solution on list for Xorg-6.9 which is to alter the gcc specs
>>file (default switches). X uses gcc for linking. The specs negate
>>-nonow, and inserts -z now. I now have specs.orig, and
>>specs.softlink in the directory
>>/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/ and copy them in as
>>appropiate. The specs.softlink leaves the linking at -nonow.
>>--
>>
>>	With best Regards,
>>
>>
>>	Declan Moriarty.
>
>Just for the fun of it, ...meh, I have recompiled 6.8.2 with a new 
>buildscript. (the buildscript has been filled with the HLFS xorg-6.8.2 
>build commands, copied from the page, so no typos (of mine) )
>Again, Xorg -configure failed, so I tried 6.9.
>I'm not sure if I understood your post correctly. I have tried with either 
>of your gcc specs files in /usr/lib/gcc/2.6.14.6/ and have built 6.9 with 
>the same 6.8.2 buildscript, except for the patches. The nonow patch could 
>actually be applied, but I'm not sure whether I still need to with these 
>spec files.
>So in total I have run four compilations of Xorg 6.9 now.
>With and without the -nonow patch and with either the specs file or the 
>specs.old file.
>
>Unfortunately, the build fails with this error:
>
>gcc -m32 -o xdm -O2 -fno-strength-reduce         -fno-strict-aliasing 
>-march=i686 -ansi -Wall -Wpointer-arith -Wundef     -L../../exports/lib   
>auth.o daemon.o
>server.o dpylist.o dm.o error.o file.o            netaddr.o reset.o 
>resource.o protodpy.o policy.o                session.o socket.o streams.o 
>util.o xdmcp.o
>mitauth.o                genauth.o access.o choose.o  prngc.o            
>xdmauth.o rpcauth.o  greet.o verify.o Login.o -lXpm -lXmu -lXt -lSM -lICE 
>-lXext -lX11 -lXt -lSM -lICE -lXext -lX11 -lXau     -lXdmcp -lrpcsvc        
>-lcrypt  -lXinerama        -Wl,-rpath-link,../../exports/lib
>/usr/bin/ld: cannot find -lrpcsvc
>collect2: ld gaf exit-status 1 terug
>make[4]: *** [xdm] Fout 1
>make[4]: Leaving directory `/usr/src/xorg/xcbuild/programs/xdm'
>make[3]: *** [all] Fout 2
>make[3]: Leaving directory `/usr/src/xorg/xcbuild/programs'
>make[2]: *** [all] Fout 2
>make[2]: Leaving directory `/usr/src/xorg/xcbuild'
>make[1]: *** [World] Fout 2
>make[1]: Leaving directory `/usr/src/xorg/xcbuild'
>make: *** [World] Fout 2
>
>(I do have /usr/include/rpcsvc/)
>
>What have I missed?
>
>Thanks, Warren
>
>_________________________________________________________________
>Don’t just search. Find. Check out the new MSN Search! 
>http://search.msn.click-url.com/go/onm00200636ave/direct/01/
>
>--
>http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
>FAQ: http://www.linuxfromscratch.org/faq/
>Unsubscribe: See the above information page

_________________________________________________________________
Is your PC infected? Get a FREE online computer virus scan from McAfee® 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963




More information about the hlfs-dev mailing list