Xorg -configure Duplicate symbol (6.8.2)

Warren Wilder wipwap19 at hotmail.com
Mon Feb 27 06:24:48 PST 2006


I compiled Xorg 6.8.2 sucessfully, but when I run Xorg -configure I get the 
following output.

/*************/

Current Operating System: Linux HLFS 2.6.14.6-grsec #17 PREEMPT Sun Feb 26 
17:42:13 CET 2006 i686
Build Date: 25 February 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 27 16:11:30 2006
Duplicate symbol __i686.get_pc_thunk.bx in 
/usr/X11R6/lib/modules/fonts/libbitmap.a:bitmapmod.o
Also defined in /usr/X11R6/lib/modules/fonts/libbitmap.a

Fatal server error:
Module load failure


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional 
information.

/*************/

Dmesg doesn't hold anymore info about the error. I read around and 
understand that this has something to do with the X module loader.
Therefore I expected an issue with this flag in the host.def file.
#define MakeDllModules    YES

I have tried building with and without it, but that didn't help.

Building  Hardened Linux From Scratch - Version SVN-20060122.
Other than X, everything seems to be fine.

I'd appreciate a few suggestions.

Greetings, Warren

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE! 
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/




More information about the hlfs-dev mailing list