virtual memory exhausted (uclibc and linux-2.6.14)

Yerp drealin01 at cox.net
Wed Nov 30 09:50:29 PST 2005


> > 3) First I recompiled Xorg 7-RC2 modular on a non-ssp system (the old
> > xorg6.8.2 monolith loves to take forevor and crash all of the time).  Which
> > then returned the following error when I call startx: "Cannot Call Assert".
> > So, I tried again, this time without using PIC patches, hacks, and
> > whatnots. Xorg stopped compiling and the linker stated that assert was
> > undefined. So, I first tried including <assert.h> in the affected files,
> > but again, the same error. Finally, I added the following to each of the
> > files:
> > #ifndef assert
> > #define assert(expr) ((void) 0)
> > #endif
> >
> > startx now works and i can even run xfce 4.2.3. BUT, xterm and other
> > programs still report "Cannot Call Assert".
> 
> I'm not familiar with this problem, but I'm using xorg-6.8.2.

Perhaps I am barking up the wrong tree, but Xorg7 and Xorg6
would both lock the screen to nothingness under the SSP+PIC system of mine. They both reported to being unable to 
link to some glx library that I cannot remember at the 
moment.  It so happened to be the same library that I had 
use the assert fix on.  The library itself existed and I 
believe I was able to reproduce the results during my test 
by using an empty main.c program and linked it to the glx 
library.  Whats stranger (to me) is that I found and 
pointed out the library that does not link properly sitting exactly where it needs to be.

  I never tested Xorg6.8.2 under the non-ssp, not-so-PIC based system.

> I'm using a pentium4 prescott, with uClibc, and an ati video card using the 
> xorg ati driver (vesa works too). I have kde running. The only problem I have 
> had is with artsd segfaulting.
> 
I am currently running a Pentium4-M with an Ati Radeon 7500.
So it seems our hardware is very similar..


I will probably drop down to a 2.6.11 kernel and try my luck
there with the only change being the kernel.




More information about the hlfs-dev mailing list