virtual memory exhausted (uclibc and linux-2.6.14)

brucem128 at comcast.net brucem128 at comcast.net
Tue Nov 29 05:36:22 PST 2005


Hi,

  I ran with just what the uclibc-config patch gives for uClibc. I have not found any problems yet. Although, I run a no-frills box.

  I am no expert, but perhaps the library you are linking with at compile time is different from the one that is loaded at runtime?

Bruce


> > 
> > From: brucem128 at comcast.net
> > Date: 2005/11/28 Mon PM 07:47:00 EST
> > To: Hardened LFS Development List <hlfs-dev at linuxfromscratch.org>
> > Subject: Re: virtual memory exhausted (uclibc and linux-2.6.14)
> > 
> > I managed to build and run xorg without issue. I have not encountered any 
> other problems compiling stuff. 
> > 
> > Bruce
> > 
> > 
> > > I'm pretty sure this is related to Xorg doing a segfault during building in 
> > > xcbuild/lib/X11.
> > > 
> 
> 1) These problems are hard to find due to too many 
> developmental wild cards. For starters, uClibc is a huge 
> change, then add the Stack-Protection, and finally add an 
> entirely PIC based system.
> 
> 2) I have noticed many strange problems under the basic 
> PIC+uClibc+SSP, so I removed PIC+SSP during this testing 
> phase.  (PIC was not completely removed as many apps pass 
> -fpic on their own..which is left as is)
> Any and all SSP patches and PIC patches were removed.
> * Note, I discovered that I cannot compile a static non-ssp 
> toolchain from a ssp system.  I had to move to a non-ssp 
> system to do this.
> 
> 3) First I recompiled Xorg 7-RC2 modular on a non-ssp system (the old xorg6.8.2 
> monolith loves to take forevor and crash all of the time).  Which then returned 
> the following error when I call startx: "Cannot Call Assert".
> So, I tried again, this time without using PIC patches, hacks, and whatnots.
> Xorg stopped compiling and the linker stated that assert was undefined.
> So, I first tried including <assert.h> in the affected files, but again, the 
> same error.
> Finally, I added the following to each of the files:
> #ifndef assert
> #define assert(expr) ((void) 0)
> #endif
> 
> startx now works and i can even run xfce 4.2.3. BUT, xterm and other programs 
> still report "Cannot Call Assert".
> 
> I think this is strange to never appear on an SSP PIC based system, to partially 
> appear on a non-ssp PIC based to system, and then to mostly appear on a non-ssp 
> mostly-non-PIC (but still *.a free) system.
> 
> Any ideas? I am still wondering why xterm and friends manage 
> to get linked despite the fact that assert does not seem to 
> get put into the binary!
> 
> Perhaps we need to know what specific hardware combinations are working and 
> which aren't with xorg and make modules_install. I only have x86 machines 
> available.
> 
> One more thing, are we all using the same configuration for the final build of 
> uClibc?  I went in and added as much support as possible as my system is not 
> embedded.  Which means a ton of glibc string support.
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
> FAQ: http://www.linuxfromscratch.org/faq/
> Unsubscribe: See the above information page



More information about the hlfs-dev mailing list