virtual memory exhausted (uclibc and linux-2.6.14)

Robert Connolly robert at linuxfromscratch.org
Mon Nov 28 20:51:56 PST 2005


On November 28, 2005 11:18 pm, Yerp wrote:
> ...
> 2) I have noticed many strange problems under the basic
> PIC+uClibc+SSP, so I removed PIC+SSP during this testing
> phase.  (PIC was not completely removed as many apps pass
> -fpic on their own..which is left as is)

-fpic is supposed to be used on shared libraries, xorg has a couple 
exceptions.

> Any and all SSP patches and PIC patches were removed.
> * Note, I discovered that I cannot compile a static non-ssp
> toolchain from a ssp system.  I had to move to a non-ssp
> system to do this.

I'm not sure what you mean. I can go from uClibc-hlfs to glibc-lfs, though I 
never tried using -fno-stack-protector on the pass1 tools.

> 3) First I recompiled Xorg 7-RC2 modular on a non-ssp system (the old
> xorg6.8.2 monolith loves to take forevor and crash all of the time).  Which
> then returned the following error when I call startx: "Cannot Call Assert".
> So, I tried again, this time without using PIC patches, hacks, and
> whatnots. Xorg stopped compiling and the linker stated that assert was
> undefined. So, I first tried including <assert.h> in the affected files,
> but again, the same error. Finally, I added the following to each of the
> files:
> #ifndef assert
> #define assert(expr) ((void) 0)
> #endif
>
> startx now works and i can even run xfce 4.2.3. BUT, xterm and other
> programs still report "Cannot Call Assert".

I'm not familiar with this problem, but I'm using xorg-6.8.2.

> I think this is strange to never appear on an SSP PIC based system, to
> partially appear on a non-ssp PIC based to system, and then to mostly
> appear on a non-ssp mostly-non-PIC (but still *.a free) system.
>
> Any ideas? I am still wondering why xterm and friends manage
> to get linked despite the fact that assert does not seem to
> get put into the binary!
>
> Perhaps we need to know what specific hardware combinations are working and
> which aren't with xorg and make modules_install. I only have x86 machines
> available.

I'm using a pentium4 prescott, with uClibc, and an ati video card using the 
xorg ati driver (vesa works too). I have kde running. The only problem I have 
had is with artsd segfaulting.

> One more thing, are we all using the same configuration for the final build
> of uClibc?  I went in and added as much support as possible as my system is
> not embedded.  Which means a ton of glibc string support.

I enable wordexp() for alsa-lib, and ipv6. Otherwise its the same as the 
default. Adding to the default config shouldn't hurt, but removing from it 
probably will.

robert



More information about the hlfs-dev mailing list