virtual memory exhausted (uclibc and linux-2.6.14)

Robert Connolly robert at linuxfromscratch.org
Mon Nov 28 15:25:25 PST 2005


I'm pretty sure this is related to Xorg doing a segfault during building in 
xcbuild/lib/X11.

This, and the below, problem is only during compile time. When I built my 
system running linux-2.6.11, then upgraded to 2.6.14, Xorg runs normally, and 
make modules_install worked.

robert

On November 28, 2005 08:26 am, brucem128 at comcast.net wrote:
> Yes, I ran into that problem as well. Similarly, I couldn't figure out how
> to fix it so I had to build my kernel with no modules...
>
> Bruce
>
> > Hi. I'm getting virtual memory exhausted errors from make modules_install
> > with kernel 2.6.14+, and uclibc. I have 1GB of ram, and another GB of
> > swap, and the error happens even after a fresh boot with most of the
> > memory free. I found one post on google with this problem, but no
> > suggestion or solution.
> > http://www.linuxquestions.org/questions/showthread.php?threadid=382824
> >
> > Are any of you having this problem? I've disabled modules for the moment.
> >
> > robert
> > --
> > http://linuxfromscratch.org/mailman/listinfo/hlfs-dev
> > FAQ: http://www.linuxfromscratch.org/faq/
> > Unsubscribe: See the above information page



More information about the hlfs-dev mailing list