2.6.11.x kernel

Robert Connolly robert at linuxfromscratch.org
Wed Mar 16 22:53:06 PST 2005


Okay. I think we should downgrade to the 2.6.11 kernel tarball and upgrade 
with patches.. fetch:

ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2
http://www.grsecurity.net/grsecurity-2.1.3-2.6.11-200503111604.patch
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-2.6.11.3
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-2.6.11.4

The patch-2.6.11.1 and patch-2.6.11.2 are included in the grsecurity patch. 
This gives us "2.6.11-grsec" but its really "2.6.11.4-grsec". Maybe an sed 
command to adjust the EXTRAVERSION would be good.

This same sort of thing happened before. Grsecurity doesn't change patch 
versions for trivial reasons.

robert



More information about the hlfs-dev mailing list