2.6.11.x kernel

pinotj at club-internet.fr pinotj at club-internet.fr
Wed Mar 16 19:22:34 PST 2005


>This 2.6.11.x series is a mess. The -as branch is still following 2.6.10. 
>Grsecurity is patching against 2.6.11 mainline. 2.6.11.3 is the latest,

The latest stable linux kernel is now 2.6.11.4. I agree that we should use the 2.6.11.x serie because it patches usually critical issue.
We could try to adapt the grsecurity patch to the current 2.6.11.x

For example, the grsecurity patch 2.1.3 contains 3 patches already apply in 2.6.11.4. Adaptation is quite easy, I did one : 

http://ngc891.blogdns.net/projects/hlfs/patches/linux-2.6.11.4-grsecurity-2.1.3.patch 

It should apply cleanly.

What do you think about this way ? It doesn't need much work.


-- 
Jerome Pinot
http://ngc891.blogdns.net/projects/hlfs 




More information about the hlfs-dev mailing list