Mozilla 1.7.5 stack overflow

Robert Connolly robert at linuxfromscratch.org
Tue Mar 8 14:34:09 PST 2005


On March 8, 2005 05:10 pm, X-Penguin wrote:
> Maybe it's wrong list, sorry...
>
> Mozilla 1.7.5 don't work with ssp (glibc). With first run it throw in log
>
> Mar  8 19:30:23 x-penguin mozilla-bin: mozilla-bin: stack overflow in
> function nsresult
> BookmarkParser::ParseBookmarkInfo(BookmarkParser::BookmarkField*,
> PRBool, const nsString&, const nsCOMPtr<nsIRDFContainer>&,
> nsIRDFResource*, nsCOMPtr<nsIRDFResource>&)()
>
> Does this error occured in mozilla or it can be in other libraries?

Use CFLAGS="-fno-stack-protector-all -fstack-protector"
should work. I'm looking for patches.

robert



More information about the hlfs-dev mailing list