stupid newbie question

Jaap Struyk japie at deserver.nl
Sat Jul 30 08:13:10 PDT 2005


Op za 23-07-2005, om 21:41 schreef Robert Connolly:

> > > You don't have to. You can use other patches, or vanilla, if you want.
> > > The grsecurity patch has a lot of nice optional features that don't
> > > reduce performance much, so I'm not sure why you wouldn't want to use it.

After spending my holliday reading an article on grsec I understand it a
bit more and will follow the lead...

> I have built a complete desktop, with kde and multimedia, with almost all the 
> grsecurity and pax options, using glibc. It should be fine. Unzip and zip 
> need tweaking to disable assembly, and kde-multimedia and some others need 
> tweaking to --disable-mmx.

Can you explain the (un)zip assembly tweeks maybe (they are not (yet) in
the book)?
And why do some apps need to disable mmx? (or did I fully understand you
wrong on that?)

I started today building beyond hlfs and ran into something weird when
compiling both ivtv and nvidia kernel modules.
The error isn't anywhere on the net (according to google) so it seems to
be hlfs (grsec/frandom) specifick.
First was ivtv:

-- 
Groetjes Japie




More information about the hlfs-dev mailing list