HLFS-SVN-20050709: iproute error

Robert Connolly robert at linuxfromscratch.org
Sat Jul 16 22:17:11 PDT 2005


On July 17, 2005 12:58 am, randhir phagura wrote:
> ...
> I have finished installing 'tool-chain' without any hitch and in the middle
> of the base HLFS system. While
> installing Iproute2-2.6.11-050314, I am getting the following error:
> ...
> make[1]: Leaving directory `/p/iproute2-2.6.11-050330/netem'
> make: *** [all] Error 2

LFS (and you) are using iproute2-2.6.11-050330 which has a known bug with ssp. 
Be sure to use iproute2-2.6.11-050314.

> Also 'Linux Frandom Patch' is not available at the site. Is there some
> other place from where I can download this patch or is there an alternative
> to do without it ?

The frandom patch was changed, sysctl urandom was added, and the patch was 
renamed to "pseudo_random":

ftp://twocents.mooo.com/pub/src/linux-2.6.11.12-pseudo_random-1.patch
http://www.linuxfromscratch.org/patches/downloads/linux/linux-2.6.12.2-pseudo_random-1.patch

Hope this helps :-)

robert



More information about the hlfs-dev mailing list