OpenSSL brokenness

Vladdy Impaler m.b.lankhorst at gmail.com
Sat Dec 31 16:32:58 PST 2005


The OpenSSL arc4random patch is broken, although it literally contains 1 
line, the line in question is wrong:
It changes:

#ifdef __OpenBSD__

to:
#ifdef __OpenBSD__ || defined(LIBC_HAS_ARC4RANDOM)

Where it should be:
#if defined(__OpenBSD__) || defined(LIBC_HAS_ARC4RANDOM)


Considering the fact that gcc even throws a compiler warning at the 
offending line, I wonder how it even made it in ;).

Maarten



More information about the hlfs-dev mailing list