hlfs nALFS --> module-init-tools error.

Declan Moriarty junk_mail at iol.ie
Tue Dec 20 00:26:28 PST 2005


Recently, Somebody Somewhere wrote these words
> Declan Moriarty wrote:
> 
> >It's promising, and many packages work well. The package.ent was a
> >bit skewed, and the guys at lfs-matrix are not up with your
> >versions. I ended up unzipping tar.gz files and running bzip2 on
> >them. Here's what I noticed (midway through chapter 5)
> > 
> >
> Wow, sorry about being asleep at the wheel.  I never saw any commit 
> messages from hlfs...oh well, I am updating it now, all mirrors will 
> sync and have the packages by tomorrow.  The mirror ftp.osuosl.org and 
> ftp.lfs-matrix.net are updated within minutes from the ftp repo if you 
> want it immediately.
> 
> Thanks for the report.

I'm most of the way along at this stage, and have some more
reports.

First of all, 'make -j6' seems to be encoded everywhere. I cannot
build large packages with that much parallel processing. The box
here is not a server but not puny (Athlon-2.6Ghz, 333Mhz FSB,
512MB ddr ram & 600Meg of swap). I have seen one disk error, (dma
timeout) one ram error (segfault) and one cpu error (tied some
registers in a knot) and gave up making large packages with it. 
All the toolchain packages are hand built (glibc, binutils, gcc,
etc.)

FWIW, the xml  _does_not_ use the package users hint.

Some errors:

Ch. 5: Running Perl testsuites is surely unnecessary, and they
cause loads more to be built which you don't need in ch 5

Ch. 6: Glibc - version now 2.3.6, couldn't attempt because of -j6
	Glibc-linuxthreads now no longer used see
	hlfs-book/chapter01/Changelog.html

Zlib-1.2.3	Patch no longer	applied
Readline	No move instruction in current specs
Vim-6.4		Compile Instructions out of date
m4-1.4.4	Sed instruction now gone; version problem
Groff-1.19.1	Wrong md5sum
Gettext-0.14.5	'Make -j6' failed. 'make' worked.
IPRoute2	make error, remade successfully by hand
		Wrong version in profile
Module-init-tools-3.2.2. Version error, and make error. 
	This halted me	last night. Here's the error

root:/tools/build/module-init-tools-3.2.2#make DOCBOOKTOMAN=""
source='lsmod.c' object='lsmod.o' libtool=no \
depfile='.deps/lsmod.Po' tmpdepfile='.deps/lsmod.TPo' \
depmode=gcc3 /bin/sh ./depcomp \

gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\"
-DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\"
-DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"module-init-tools\"
-DVERSION=\"3.2.2\" -DCONFIG_USE_ZLIB=1  -I. -I.
  -g -O2 -Wunused -Wall -pie -fpie -c `test -f 'lsmod.c' || echo
'./'`lsmod.c

gcc  -g -O2 -Wunused -Wall -pie -fpie   -o lsmod  lsmod.o
-Wl,-Bdynamic -lz
/tools/lib/gcc/i686-tools-linux-gnu/3.4.4/../../../../i686-tools-linux-gnu/bin/ld:
cannot find -lz
collect2: ld returned 1 exit status
make: *** [lsmod] Error 1
root:/tools/build/module-init-tools-3.2.2#

Taking a quick look

[root@ ... build/module-init-tools-3.2.2]# grep -re '-lz' * |less
config.log:LDADD=' -Wl,-Bdynamic -lz'
config.status:s, at LDADD@, -Wl,-Bdynamic -lz,;t t
configure:  zlib_flags="-Wl,-Bdynamic -lz"
configure.in:  zlib_flags="-Wl,-Bstatic -lz -Wl,-Bdynamic"
Makefile:LDADD =  -Wl,-Bdynamic -lz

Is that kosher?

	
Remember, this is the box that _can't_construct_hardened-specs.sh.
That looks awfully like the same error type there, but I really don't
know yet. Does module-init-tools build without the patch?

If anyone has any idea what's wrong with the host system, please
throw me a bone on this. I'm suspecting framebuffer/radeon issues.

BTW, there's no patch for module-init-tools-3.2.2. I used the
patch from module-init-tools-3.1.0, which applied with no fuss. Is
it needed anymore?

-- 

	With best Regards,


	Declan Moriarty.



More information about the hlfs-dev mailing list